Skip to content

ChromeOS 68.0.3437.0 Brings Shared Clipboards and The Ability To Access Linux Filesystems To The ChromeOS File Manager


ChromeOS 68.0.3437.0 was released for Pixelbook owners on the “dev” channel on Wednesday and it brings several changes and bug fixes. I have spent the past few days playing around with this release and here is what has changed:

Disclaimer: This Page Has Been Archived

Please note that this blog post has been archived and may contain information that is outdated, defunct, or covers topics that are no longer of interest. It is being kept available solely for reference purposes, in case others might find portions of it useful.

For more recent and up-to-date tutorials, I recommend visiting or other websites that specialize in the topic you are interested in. It is always advisable to seek the most current information to ensure accuracy and relevance.

New Features

Shared Clipboard Support

When Project Crostini first started to appear on my Pixelbook, I wrote a blog post describing several of the limitations of Crostini. One of the major issues I reported was the lack of a shared clipboard which will cause pain to many developers. I first noticed that the clipboard tried to work in ChromeOS68.0.3431.0 last week but it was way too buggy to actually want to use. It does however seem fully functional in ChromeOS 68.0.3437.0.

What makes this Shared Clipboard interesting is that this is actually a tri-directional shared clipboard instead of a bi-directional. The clipboard is shared between ChromeOS, Linux and Android! This means you can copy something like SFTP credentials from a Android based Password Manager and paste it into a Linux application.

Linux Filesystem Access in ChromeOS

Likely the most welcomed addition to ChromeOS68.0.3437.0 is that your ChromeOS file manager can now view the contents of your Linux container’s home directory (/home/username/). You can open, modify and delete files as if you were accessing a flash drive. Thanks to this change, hacks requiring you to setup a SFTP mount are no longer needed.

There are a few limitations with the way the file manager works that you should be aware of:

  • It may take a few seconds on a cold boot for the Virtual Machine and Container to start if you click on “Linux Files” after a cold boot. Every other time should be instant
  • You are bound adhering to *nix file permissions. All files you create will be owned by you however you cannot modify files owned by other users
  • You are limited to your home directory. If you wanted to move contents into another location such as /var/www/html, you would need to first copy it to a folder in your home directory and then move it to your desired location via command line.
  • The ChromeOS file manager does not like Symlinks – I tried

Bug Fixes

The Terminal Works again

Last weeksChromeOS68.0.3431.0 update rendered the Terminal Application useless therefore requiring users to either use the old fashioned crosh method to access their container or to install Gnome-Shell. I am happy to report that after installingChromeOS 68.0.3437.0, the default Terminal Application once again works.